connectViewportViews Function
Form a connection between two or more Viewports such that every aspect of the viewports are kept in sync. For example, if the set of models
or categories visible in one viewport is changed, the same set of models and categories will be visible in the other viewports.
connectViewportViews(viewports: Iterable<Viewport>): () => void
see connectViewportFrusta to synchronize only the Frustum of each viewport.
see connectViewports to customize how the viewports are synchronized.
extensions
Parameter | Type | Description |
---|---|---|
viewports | Iterable<Viewport> |
Returns - () => void
Defined in
- core/frontend/src/ViewportSync.ts Line 128
Last Updated: 20 June, 2023