get Method
Method to get a user preference based off of a key within a namespace.
If both iTwinId and iModelId are provided, the iModel level will be check first. If it does not exist, the iTwin level will checked next.
get(arg: PreferenceKeyArg & ITwinIdArg & TokenArg): Promise<any>
throws if an error occurs when attempting to retrieve a preference.
Parameter | Type | Description |
---|---|---|
arg | PreferenceKeyArg & ITwinIdArg & TokenArg |
Returns - Promise<any>
undefined if a preference is not found.
Defined in
Last Updated: 20 June, 2023