run Method
Look up a tool by toolId and, if found, create an instance with the supplied arguments and run it.
run(toolId: string, ...args: any[]): Promise<boolean>
Parameter | Type | Description |
---|---|---|
toolId | string | toolId of the immediate tool |
...args | any[] | arguments to pass to the constructor, and to run. |
Returns - Promise<boolean>
true if the tool was found and successfully run.
Defined in
- core/frontend/src/tools/Tool.ts Line 1008
Last Updated: 20 June, 2023