exceptionHandler MethodStatic
A function that catches otherwise-uncaught exceptions occurring inside ToolAdmin.eventLoop. To customize the behavior of this function, modify ToolAdmin.exceptionOptions. To replace it within your own handler, simply assign to it, e.g.:
ToolAdmin.exceptionHandler = (exception: any): Promise<any> => {
... your implementation here
}
exceptionHandler(exception: any): Promise<any>
Parameter | Type | Description |
---|---|---|
exception | any |
Returns - Promise<any>
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 398
Last Updated: 20 June, 2023