dispatchUiSyncEvent Method
Beta
Method used by interactive tools to inform one or more UI components to refresh. This is typically used to update labels or icons associated with a specific tool. This method should be used when the caller wants the UI layer to process the sync event on a timer, waiting a few 100 ms, allowing other events that may require a UI refresh to be processed together.
dispatchUiSyncEvent(specificSyncEventId?: string, toolId?: string): void
Returns - void
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 1692
Last Updated: 20 June, 2023