defaultToolId
Accessor
The name of the PrimitiveTool to use as the default tool. Defaults to "Select", referring to SelectionTool.
defaultToolId: string
see ToolAdmin.startDefaultTool to activate the default tool.
see ToolAdmin.defaultToolArgs to supply arguments when starting the tool.
Returns - string
Setter
The name of the PrimitiveTool to use as the default tool. Defaults to "Select", referring to SelectionTool.
defaultToolId(toolId: string): void
see ToolAdmin.startDefaultTool to activate the default tool.
see ToolAdmin.defaultToolArgs to supply arguments when starting the tool.
Parameter | Type | Description |
---|---|---|
toolId | string |
Returns - void
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 351
Last Updated: 20 June, 2023