convertTouchMoveStartToButtonDownAndMotion Method
Can be called by tools that wish to emulate moving the mouse with a button depressed for onTouchMoveStart.
convertTouchMoveStartToButtonDownAndMotion(startEv: BeTouchEvent, ev: BeTouchEvent, button: BeButton = BeButton.Data): Promise<void>
note Calls the tool's onMouseStartDrag method from onMotion.
Parameter | Type | Description |
---|---|---|
startEv | BeTouchEvent | |
ev | BeTouchEvent | |
button | BeButton |
Returns - Promise<void>
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 1794
Last Updated: 20 June, 2023