bumpToolSetting Method
Beta
Method used to "bump" the value of a tool setting for the current tool.
To "bump" a setting means to toggle a boolean value or cycle through enum values.
If no settingIndex
param is specified, the first setting is bumped.
Returns true if the setting was successfully bumped.
bumpToolSetting(settingIndex?: number): Promise<boolean>
Parameter | Type | Description |
---|---|---|
settingIndex | number |
Returns - Promise<boolean>
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 1662
Last Updated: 20 June, 2023