initLocateElements Method
Helper method for tools that need to locate existing elements. Initializes ElementLocateManager, changes the view cursor to locate, enables display of the locate circle, and sets the appropriate coordinate lock overrides.
initLocateElements(enableLocate: boolean = true, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void
see InteractiveTool.changeLocateState
Parameter | Type | Description |
---|---|---|
enableLocate | boolean | |
enableSnap | boolean | |
cursor | string | |
coordLockOvr | CoordinateLockOverrides |
Returns - void
Defined in
- core/frontend/src/tools/Tool.ts Line 725
Last Updated: 20 June, 2023