getDecorationGeometry Method
Called to allow snapping to pickable decoration geometry.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps
note Snap geometry can be different from decoration geometry (ex. center point of a + symbol). Valid decoration geometry for snapping should be "stable" and not change based on the current cursor location.
Parameter | Type | Description |
---|---|---|
_hit | HitDetail |
Returns - undefined | GeometryStreamProps
Defined in
- core/frontend/src/tools/Tool.ts Line 529
Last Updated: 20 June, 2023