bumpToolSetting Method
Used to "bump" the value of a tool setting. To "bump" a setting means to toggle a boolean value or cycle through enum values.
If no settingIndex
param is specified, the first setting is bumped.
Return true if the setting was successfully bumped.
bumpToolSetting(_settingIndex?: number): Promise<boolean>
Parameter | Type | Description |
---|---|---|
_settingIndex | number |
Returns - Promise<boolean>
Defined in
- core/frontend/src/tools/Tool.ts Line 845
Last Updated: 20 June, 2023