TileRequest.State Enumeration
The states through which a TileRequest proceeds. During the first 3 states, the Tile's request
member is defined,
and its Tile.LoadStatus is computed based on the state of its request.
@ public
Members
Name |
Value |
Description |
Queued |
0 |
Initial state. Request is pending but not yet dispatched. |
Dispatched |
1 |
Follows Queued when request begins to be actively processed. |
Loading |
2 |
Follows Dispatched when the response to the request is being converted into tile graphics. |
Completed |
3 |
Follows Loading when tile graphic has successfully been produced. |
Failed |
4 |
Follows any state in which an error prevents progression, or during which the request was canceled. |
Defined in
Last Updated:
20 June, 2023