TileLoadStatus Enumeration
Describes the current status of a Tile's content. Tile content is loaded via an asynchronous TileRequest.
see Tile.loadStatus.
extensions
Members
Name |
Value |
Description |
NotLoaded |
0 |
No attempt to load the tile's content has been made, or the tile has since been unloaded. It currently has no graphics. |
Queued |
1 |
A request has been dispatched to load the tile's contents, and a response is pending. |
Loading |
2 |
A response has been received and the tile's graphics and other data are being loaded on the frontend. |
Ready |
3 |
The tile has been loaded, and if the tile is displayable it has graphics. |
NotFound |
4 |
A request to load the tile's contents failed. |
Abandoned |
5 |
The tile has been disposed. |
Defined in
Last Updated:
20 June, 2023