markUsed Method

Indicate that the specified tile is being used for some purpose by the SceneContext's Viewport. Typically "used" means "displayed", but the exact meaning is up to the TileTree - for example, "used" might also mean that the tile's children are being used. A tile that is "in use" by any Viewport will not be discarded.

markUsed(tile: Tile): void

Parameter Type Description
tile Tile  

Returns - void

Defined in

Last Updated: 20 June, 2023