defaultTileSizeModifier
Accessor
A default multiplier applied to the size in pixels of a Tile during tile selection for any Viewport. Individual Viewports can override this multiplier if desired. A value greater than 1.0 causes lower-resolution tiles to be selected; a value < 1.0 selects higher-resolution tiles. This can allow an application to sacrifice quality for performance or vice-versa. This property is initialized from the value supplied by the TileAdmin.Props.defaultTileSizeModifier used to initialize the TileAdmin at startup. Changing it after startup will change it for all Viewports that do not explicitly override it with their own multiplier. This value must be greater than zero.
defaultTileSizeModifier: number
Returns - number
Setter
A default multiplier applied to the size in pixels of a Tile during tile selection for any Viewport. Individual Viewports can override this multiplier if desired. A value greater than 1.0 causes lower-resolution tiles to be selected; a value < 1.0 selects higher-resolution tiles. This can allow an application to sacrifice quality for performance or vice-versa. This property is initialized from the value supplied by the TileAdmin.Props.defaultTileSizeModifier used to initialize the TileAdmin at startup. Changing it after startup will change it for all Viewports that do not explicitly override it with their own multiplier. This value must be greater than zero.
defaultTileSizeModifier(modifier: number): void
Parameter | Type | Description |
---|---|---|
modifier | number |
Returns - void
Defined in
- core/frontend/src/tile/TileAdmin.ts Line 365
Last Updated: 20 June, 2023