fromRadians MethodStatic
Create a new rectangle with angles specified in radians.
fromRadians(west: number, south: number, east: number, north: number, result?: MapCartoRectangle): MapCartoRectangle
note If north
is less than south
, they will be swapped.
Parameter | Type | Description |
---|---|---|
west | number | The western longitude in radians, in [-pi, pi]. |
south | number | The southern latitude in radians, in [-pi/2, pi/2]. |
east | number | The eastern latitude in radians, in [-pi, pi]. |
north | number | The northern latitude in radians, in [-pi/2, pi/2]. |
result | MapCartoRectangle | An optional preallocated rectangle to hold the result. |
Returns - MapCartoRectangle
Defined in
Last Updated: 20 June, 2023