fromDegrees MethodStatic
Create a new rectangle with angles specified in degrees.
fromDegrees(west: number, south: number, east: number, north: number, result?: MapCartoRectangle): MapCartoRectangle
note If north
is less than south
, they will be swapped.
Parameter | Type | Description |
---|---|---|
west | number | The western longitude in degrees, in [-180, 180]. |
south | number | The southern latitude in degrees, in [-90, 90]. |
east | number | The eastern latitude in degrees, in [-180, 180]. |
north | number | The northern latitude in degrees, in [-90, 90]. |
result | MapCartoRectangle | An optional preallocated rectangle to hold the result. |
Returns - MapCartoRectangle
Defined in
Last Updated: 20 June, 2023