UniformArrayParams Interface
Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program.
see ScreenSpaceEffectBuilder.addUniformArray to add a uniform array to an effect shader.
extensions
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
bind(uniform: Uniform, context: UniformContext): void | UniformParams | A function that computes the value of the variable and binds it to the shader program each time the effect is rendered. |
Properties
Name | Type | Description | |
---|---|---|---|
length | number | The number of elements in the array. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name | string | UniformParams | The name of the variable. |
type | UniformType | UniformParams | The data type of the uniform variable. |
Defined in
Last Updated: 20 June, 2023