QueryScreenFeaturesOptions Interface
Options specifying how to query for visible Features by reading pixels rendered by a Viewport. This method of determining visibility considers a feature "visible" if it lit up at least one pixel.
note A pixel that is behind another, transparent pixel is not considered visible.
see QueryVisibleFeaturesOptions.
Properties
Name | Type | Description | |
---|---|---|---|
includeNonLocatable | undefined | boolean | If true, non-locatable features are considered visible. | |
rect | undefined | ViewRect | If specified, a sub-region of the Viewport to which to constrain the query. | |
source | "screen" | Union discriminator for QueryVisibleFeaturesOptions. |
Defined in
Last Updated: 20 June, 2023