addArc2d MethodAbstract
Appends a 2d open arc or closed ellipse to the builder.
addArc2d(ellipse: Arc3d, isEllipse: boolean, filled: boolean, zDepth: number): void
Parameter | Type | Description |
---|---|---|
ellipse | Arc3d | |
isEllipse | boolean | If true, and if the arc defines a full sweep, then draw as a closed ellipse instead of an arc. |
filled | boolean | If true, and isEllipse is also true, then draw ellipse filled. |
zDepth | number | Z value in local coordinates to use for each point in the arc or ellipse. |
Returns - void
Defined in
Last Updated: 20 June, 2023