addArc MethodAbstract
Appends a 3d open arc or closed ellipse to the builder.
addArc(arc: Arc3d, isEllipse: boolean, filled: boolean): void
Parameter | Type | Description |
---|---|---|
arc | Arc3d | Description of the arc or ellipse. |
isEllipse | boolean | If true, and if the arc defines a full sweep, then draw as a closed ellipse instead of an arc. |
filled | boolean | If true, and isEllipse is also true, then draw ellipse filled. |
Returns - void
Defined in
Last Updated: 20 June, 2023