activatePickableId Method
Change the pickable Id to be associated with subsequently-added geometry. This permits multiple pickable objects to be batched together into a single graphic for more efficient rendering. This method calls GraphicBuilder.activateFeature, using the subcategory Id and GeometryClass specified in GraphicBuilder.pickable at construction, if any.
activatePickableId(id: string): void
note This method has no effect if GraphicBuilderOptions.pickable was not supplied to the GraphicBuilder's constructor.
Parameter | Type | Description |
---|---|---|
id | string |
Returns - void
Defined in
Last Updated: 20 June, 2023