emphasizeSelectedElements Method
Set the currently selected elements to be always drawn normally with all other elements in the view overridden to draw using a default appearance.
emphasizeSelectedElements(vp: Viewport, defaultAppearance?: FeatureAppearance, replace: boolean = true, clearSelection: boolean = true): boolean
see Viewport.isAlwaysDrawnExclusive
Parameter | Type | Description |
---|---|---|
vp | Viewport | The viewport. |
defaultAppearance | FeatureAppearance | Optional default appearance, uses transparent grey if not specified. |
replace | boolean | true to replace currently overridden elements (if any) or false to add to the existing set. |
clearSelection | boolean | true to clear current selection after setting appearance override, false to leave selected. |
Returns - boolean
true if overrides were changed.
Defined in
Last Updated: 20 June, 2023