emphasizeElements Method
Set the element IDs to be always drawn normally with all other elements in the view overridden to draw using a default appearance.
emphasizeElements(ids: Id64Arg, vp: Viewport, defaultAppearance?: FeatureAppearance, replace: boolean = true): boolean
see Viewport.isAlwaysDrawnExclusive
Parameter | Type | Description |
---|---|---|
ids | Id64Arg | The IDs of the elements to always draw. |
vp | Viewport | The viewport. |
defaultAppearance | FeatureAppearance | Optional default appearance, uses non-locatable transparent grey if not specified. |
replace | boolean | true to replace currently overridden elements (if any) or false to add to the existing set. |
Returns - boolean
true if overrides were changed.
Defined in
Last Updated: 20 June, 2023