defaultAppearance
Accessor
Establish a default appearance to apply to elements without overrides. If changing the default appearance without also calling overrideElements, an explicit refresh must be requested for the change to take effect.
defaultAppearance: undefined | FeatureAppearance
see Viewport.setFeatureOverrideProviderChanged
Returns - undefined | FeatureAppearance
Setter
Establish a default appearance to apply to elements without overrides. If changing the default appearance without also calling overrideElements, an explicit refresh must be requested for the change to take effect.
defaultAppearance(appearance: undefined | FeatureAppearance): void
see Viewport.setFeatureOverrideProviderChanged
Parameter | Type | Description |
---|---|---|
appearance | undefined | FeatureAppearance |
Returns - void
Defined in
Last Updated: 20 June, 2023