TextSelectFormatPropEditorSpec Interface
TextSelectFormatPropEditorSpec defines getter and setter method for a Select/Dropdown property editor.
Extends
Methods
Name | Description | |
---|---|---|
getString(props: FormatProps): string | ||
setString(props: FormatProps, value: string): FormatProps |
Properties
Name | Type | Description | |
---|---|---|---|
editorType | "select" | ||
selectOptions | { label: string, value: string }[] |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
label | string | CustomFormatPropEditorSpec |
Defined in
Last Updated: 20 June, 2023