FormatterParserSpecsProvider Interface
Interface that defines the functions required to be implemented to provide custom formatting and parsing of a custom quantity type.
Methods
Name | Description | |
---|---|---|
createFormatterSpec(unitSystem: UnitSystemKey): Promise<FormatterSpec> | Async function to return FormatterSpec for a custom quantity type | |
createParserSpec(unitSystem: UnitSystemKey): Promise<ParserSpec> | Async function to return ParserSpec for a custom quantity type |
Properties
Name | Type | Description | |
---|---|---|---|
quantityType | QuantityTypeArg | Custom quantity id |
Defined in
Last Updated: 20 June, 2023