send MethodStatic
Send a message over the socket.
send(channel: string, ...data: any[]): void
note data
is serialized with the Structured Clone Algorithm, so only
primitive types and ArrayBuffers
are allowed.
Parameter | Type | Description |
---|---|---|
channel | string | The name of the channel for the message. |
...data | any[] | The optional data of the message. |
Returns - void
Defined in
- core/frontend/src/IpcApp.ts Line 79
Last Updated: 20 June, 2023