invoke MethodStatic
Send a message to the backend via channel
and expect a result asynchronously. The handler must be established on the backend via BackendIpc.handle
invoke(channel: string, ...args: any[]): Promise<any>
see Electron ipcRenderer.invoke documentation for details. Note that this interface may be implemented via Electron for desktop apps, or via WebSockets for mobile or web-based Ipc connections. In either case, the Electron documentation provides the specifications for how it works.
note args
are serialized with the Structured Clone Algorithm, so only
primitive types and ArrayBuffers
are allowed.
Parameter | Type | Description |
---|---|---|
channel | string | The name of the channel for the method. |
...args | any[] |
Returns - Promise<any>
Defined in
- core/frontend/src/IpcApp.ts Line 68
Last Updated: 20 June, 2023