constructor Method
Constructor for SnapDetail.
SnapDetail(from: HitDetail, snapMode: SnapMode = SnapMode.Nearest, heat: SnapHeat = SnapHeat.None, snapPoint?: XYZProps): SnapDetail
Parameter | Type | Description |
---|---|---|
from | HitDetail | The HitDetail that created this snap |
snapMode | SnapMode | The SnapMode used to create this SnapDetail |
heat | SnapHeat | The SnapHeat of this SnapDetail |
snapPoint | XYZProps | The snapped point in the element |
Returns - SnapDetail
Defined in
- core/frontend/src/HitDetail.ts Line 224
Last Updated: 20 June, 2023