getContextRotation MethodStatic
Return a Matrix3d corresponding to the supplied ContextRotationId. A ContextRotationId that corresponds to a standard view, "Top", "Front", etc. will return a Matrix3d that is relative to the current Viewport.auxCoordSystem when ACS context lock is enabled.
getContextRotation(id: ContextRotationId, vp: Viewport): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
id | ContextRotationId | |
vp | Viewport |
Returns - undefined | Matrix3d
Defined in
- core/frontend/src/AccuDraw.ts Line 3350
Last Updated: 20 June, 2023