modelClipGroups
Accessor
Groups of models associated with ClipVectors by which those models should be clipped. If the view and the model both have a clip vector defined, geometry in the model will be clipped by the intersection of the two clip vectors. ViewFlags.clipVolume has no effect on model clips, only the view clip - model clips are always applied.
modelClipGroups: ModelClipGroups
note Do not modify the returned object directly. Instead, clone it, modify the clone, and pass the clone to the property setter.
Returns - ModelClipGroups
Setter
Groups of models associated with ClipVectors by which those models should be clipped. If the view and the model both have a clip vector defined, geometry in the model will be clipped by the intersection of the two clip vectors. ViewFlags.clipVolume has no effect on model clips, only the view clip - model clips are always applied.
modelClipGroups(groups: ModelClipGroups): void
note Do not modify the returned object directly. Instead, clone it, modify the clone, and pass the clone to the property setter.
Parameter | Type | Description |
---|---|---|
groups | ModelClipGroups |
Returns - void
Defined in
- core/common/src/ViewDetails.ts Line 209
Last Updated: 20 June, 2023