describeAvailableEndpoints MethodStatic
Describes the RPC interfaces and endpoints that are currently available from the backend.
describeAvailableEndpoints(): Promise<RpcInterfaceEndpoints[]>
note Some endpoints may be marked incompatible if the frontend expected a different interface declaration than the backend supplied. RPC operations against an incompatible interface will fail.
Returns - Promise<RpcInterfaceEndpoints[]>
Defined in
- core/common/src/RpcManager.ts Line 66
Last Updated: 20 June, 2023