overrideSubCategory Method
Deprecated in 3.x. Use FeatureOverrides.override.
Specify overrides for all geometry belonging to the specified SubCategory.
overrideSubCategory(id: string, app: FeatureAppearance, replaceExisting: boolean = true): void
note These overrides have lower priority than element and model overrides.
note If FeatureOverrides.defaultOverrides are defined, they will not apply to any geometry within this subcategory, even if the supplied appearance overrides nothing.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory. |
app | FeatureAppearance | The symbology overrides. |
replaceExisting | boolean | Specifies whether to replace a pre-existing override for the same subcategory. |
Returns - void
Defined in
- core/common/src/FeatureSymbology.ts Line 738
Last Updated: 20 June, 2023