overrideModel Method
Deprecated in 3.x. Use FeatureOverrides.override.
Specify overrides for all elements within the specified model.
overrideModel(id: string, app: FeatureAppearance, replaceExisting: boolean = true): void
note These overrides take priority over all other overrides.
note If FeatureOverrides.defaultOverrides are defined, they will not apply to any element within this model, even if the supplied appearance overrides nothing.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the model. |
app | FeatureAppearance | The symbology overrides. |
replaceExisting | boolean | Specifies whether to replace a pre-existing override for the same model. |
Returns - void
Defined in
- core/common/src/FeatureSymbology.ts Line 726
Last Updated: 20 June, 2023