overrideElement Method
Deprecated in 3.x. Use FeatureOverrides.override.
Specify overrides for all geometry originating from the specified element.
overrideElement(id: string, app: FeatureAppearance, replaceExisting: boolean = true): void
note These overrides take precedence over subcategory overrides, but not over model overrides.
note If FeatureOverrides.defaultOverrides are defined, they will not apply to this element, even if the supplied appearance overrides nothing.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the element. |
app | FeatureAppearance | The symbology overrides. |
replaceExisting | boolean | Specifies whether to replace a pre-existing override for the same element. |
Returns - void
Defined in
- core/common/src/FeatureSymbology.ts Line 750
Last Updated: 20 June, 2023