unquantize Method
Returns the unquantized point at the specified index in QPoint2dBufferBuilder.buffer.
unquantize(pointIndex: number, result?: Point2d): Point2d
throws Error if pointIndex
is out of bounds.
Parameter | Type | Description |
---|---|---|
pointIndex | number | The index of the point of interest, ranging from zero to one minus the number of points currently in the QPoint2dBufferBuilder.buffer. |
result | Point2d | If supplied, a Point2d to initialize with the result and return. |
Returns - Point2d
The unquantized point at the specified index in QPoint2dBufferBuilder.buffer.
Defined in
- core/common/src/QPoint.ts Line 895
Last Updated: 20 June, 2023