appendGeometryPart2d Method
Append a GeometryPart instance with relative position, orientation, and scale to a GeometryStreamProps array for creating a GeometricElement2d. Not valid when defining a GeometryPart as nesting of parts is not supported.
appendGeometryPart2d(partId: string, instanceOrigin?: Point2d, instanceRotation?: Angle, instanceScale?: number): boolean
Parameter | Type | Description |
---|---|---|
partId | string | |
instanceOrigin | Point2d | |
instanceRotation | Angle | |
instanceScale | number |
Returns - boolean
Defined in
Last Updated: 20 June, 2023