copy Method
Produce a copy of these ViewFlags with some modified properties. Any properties not explicitly specified by changedFlags
will retain their current values.
copy(changedFlags: Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>): ViewFlags
note Any explicitly undefined
property of changedFlags
will be set to its default value in the returned ViewFlags.
see ViewFlags.override to have undefined
properties retain their current values.
Parameter | Type | Description |
---|---|---|
changedFlags | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | Properties to modify. |
Returns - ViewFlags
A copy of these ViewFlags modified according to the supplied properties.
Defined in
- core/common/src/ViewFlags.ts Line 265
Last Updated: 20 June, 2023