constructor Method
Construct a new DisplayStyleSettings from an ElementProps.jsonProperties.
DisplayStyleSettings(jsonProperties: { styles?: DisplayStyleSettingsProps }, options?: DisplayStyleSettingsOptions): DisplayStyleSettings
note When the DisplayStyleSetting
's properties are modified by public setters, the jsonProperties
's styles
object will be updated to reflect the change.
note If jsonProperties
contains no styles
member, one will be added as an empty object.
note Generally there is no reason to create an object of this type directly; a DisplayStyle or DisplayStyleState constructs one as part of its own construction.
Parameter | Type | Description |
---|---|---|
jsonProperties | { styles?: DisplayStyleSettingsProps } | An object with an optional styles property containing a display style's settings. |
options | DisplayStyleSettingsOptions | Options for customizing the display style settings. |
Returns - DisplayStyleSettings
Defined in
Last Updated: 20 June, 2023