omit Function
A runtime property omitter, makes a shallow copy of the given object without the specified properties
Compatible with the typescript Omit
mapped type:
const testvar: Omit<{x: string, y: object}, "y"> = omit({x: "hello", y: {}}, ["y"]);
omit<T extends { T }, K extends undefined>(t: T, keys: K): Omit<T, >
Parameter | Type | Description |
---|---|---|
t | T | |
keys | K |
Returns - Omit<T, >
Defined in
- core/bentley/src/UtilityTypes.ts Line 113
Last Updated: 20 June, 2023