executeAfter Method

Execute a function after delaying by this duration.

executeAfter<T>(fn: (...args: any[]) => T, scope?: any, ...args: any[]): Promise<T>

Parameter Type Description
fn (...args: any[]) => T the function to execute after the delay
scope any An optional object scope to serve as the 'this' pointer when fn is invoked.
...args any[] optional arguments to fn

Returns - Promise<T>

Promise resolved by fn

Defined in

Last Updated: 20 June, 2023