logException MethodStatic
Log the specified exception. The special "ExceptionType" property will be added as metadata, in addition to any other metadata that may be supplied by the caller, unless the metadata supplied by the caller already includes this property.
logException(category: string, err: any, log: LogFunction = Logger.logError): void
Parameter | Type | Description |
---|---|---|
category | string | The category of the message. |
err | any | The exception object. |
log | LogFunction | The logger output function to use - defaults to Logger.logError |
Returns - void
Defined in
- core/bentley/src/Logger.ts Line 235
Last Updated: 20 June, 2023