Ids
Classes for working with unique identifiers.
Classes
Name | Description | |
---|---|---|
MutableCompressedId64Set | A mutable set of valid Id64Strings sorted in ascending order by the 64-bit unsigned integer value of the Ids. | |
OrderedId64Array | A SortedArray of unique Id64Strings sorted in ascending order by the 64-bit unsigned integer values of the Ids. | |
TransientIdSequence | Generates unique Id64String values in sequence, which are guaranteed not to conflict with Ids associated with persistent elements or models. |
Namespaces
Name | Description | |
---|---|---|
CompressedId64Set | A compact string representation of an Id64Set. | |
Guid | The Guid namespace provides facilities for working with GUID strings using the "8-4-4-4-12" pattern. | |
Id64 | The Id64 namespace provides facilities for working with 64-bit identifiers. | |
OrderedId64Iterable | A collection of valid Id64Strings sorted in ascending order by the unsigned 64-bit integer value of the Ids. |
Type Aliases
Name | Description | |
---|---|---|
CompressedId64Set | ||
GuidString | A string containing a well-formed string representation of a Guid. | |
Id64Arg | Used as an argument to a function that can accept one or more Id64Strings. | |
Id64Array | An array of Id64Strings. | |
Id64Set | A set of Id64Strings. | |
Id64String | A string containing a well-formed string representation of an Id64. | |
OrderedId64Iterable |
Last Updated: 20 June, 2023