getErrorMetadata MethodStatic
Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorMetadata(error: unknown): undefined | object
note It's recommended to use this function in catch
clauses, where a caught value cannot be assumed to be instanceof BentleyError
Parameter | Type | Description |
---|---|---|
error | unknown |
Returns - undefined | object
Defined in
- core/bentley/src/BentleyError.ts Line 724
Last Updated: 20 June, 2023