ensureBytesPerElement MethodProtected
Ensures that the underlying array is of a type that can contain the largest value in newValues
.
For example, if _data
is a Uint16Array
and newValues
contains any value(s) larger than 65,535, it will be replaced with a Uint32Array
.
This method is invoked by UintArrayBuilder.push and UintArrayBuilder.append.
ensureBytesPerElement(newValues: Iterable<number>): void
Parameter | Type | Description |
---|---|---|
newValues | Iterable<number> |
Returns - void
Defined in
Last Updated: 20 June, 2023