constructor Method

Construct a new IndexMap.

IndexMap<T>(compare: OrderedComparator<T, T>, maximumSize: number = Number.MAX_SAFE_INTEGER, clone: CloneFunction<T> = shallowClone): IndexMap<T>

Parameter Type Description
compare OrderedComparator<T, T> The function used to compare elements within the map.
maximumSize number The maximum number of elements permitted in the IndexMap. The maximum index of an element is maximumSize-1.
clone CloneFunction<T> The function invoked to clone a new element for insertion into the array. The default implementation simply returns its input.

Returns - IndexMap<T>

Defined in

Last Updated: 20 June, 2023