getFile Method
Extract a local copy of a file resource from this WorkspaceDb, if present.
getFile(rscName: string, targetFileName?: string): undefined | string
note The file is copied from the file into the local filesystem so it may be accessed directly. This happens only as necessary, if the local file doesn't exist, or if it is out-of-date because it was updated in the file. For this reason, you should not save the local file name, and instead call this method every time you access it, so its content is always holds the correct version.
note The filename will be a hash value, not the resource name.
note Workspace resource files are set readonly as they are copied from the file. To edit them, you must first copy them to another location.
Returns - undefined | string
the full path to a file on the local filesystem.
Last Updated: 20 June, 2023