createCode MethodStatic
Create a Code for a ViewDefinition given a name that is meant to be unique within the scope of the specified DefinitionModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModelDb |
scopeModelId | string | The Id of the DefinitionModel to contain the ViewDefinition and provides the scope for its name. |
codeValue | string | The ViewDefinition name |
Returns - Code
Defined in
- backend/src/ViewDefinition.ts Line 281
Last Updated: 20 June, 2023