createCode MethodStatic
Create a Code for a CategorySelector given a name that is meant to be unique within the scope of the specified DefinitionModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModelDb |
scopeModelId | string | The Id of the DefinitionModel that contains the CategorySelector and provides the scope for its name. |
codeValue | string | The CategorySelector name |
Returns - Code
Defined in
- backend/src/ViewDefinition.ts Line 132
Last Updated: 20 June, 2023